Ragdoll Intro as of 2023.04.xx

Hi everyone,

Posted this already in the Livestream I - Intro - #3 by marcus thread but since it’s a brand new tutorial covering Ragdoll as of 2023.04 I figure it would be worth shedding some more light on it in its own thread.



When I select a marker, which it seems I can only do by using the manipulator tool in RD, I cannot shift select on a mesh to create a new marker. Is there a new way of doing this?

Welcome to the forums @Leethul! :partying_face:

To replace a mesh using the Manipulator, here’s what you can do.

  1. Enter the Manipulator (hotkey: T)
  2. Select a Marker
  3. Exit the Manipulator (hotkey: Q)
  4. Shift + Select a Mesh
  5. Run Ragdoll → Utilities → Replace Mesh

There are 4 ways you can select a Marker.

  1. Via the Manipulator
  2. Via the Outliner, as a DG node
  3. Via the Channel Box
  4. Via the Attribute Editor

Select via Outliner

Untick the Show DAG Shapes Only toggle to see “DG” nodes.

Select via Channel Box

With a control selected, the Marker will appear in the Channel Box. Once selected, you can optionally deselect the original controller, to end up with only the Marker selected.

Select via Attribute Editor

The Select button at the bottom will replace your selection with only the Marker.

OK, got it to work, thanks, Marcus!

1 Like

@marcus I’m walking through your examples here in this vid. I’m selecting the marker, hitting “q” then shift selecting the mesh and I’m getting the error. I tried Ctrl selecting in the outliner and still getting the same error. What am I missing?

This one has my mouse curser.

When the command is run, ensure that both mesh + marker are selected, the Marker will also be outlined in the viewport.

You can find Markers in the Outliner by unckecking Show DAG Objects Only