Users are Continuing to Receive Trial Licenses after Starting our License Server

Hello, we’re seeing some users report that Ragdoll is continuing to find Trial licenses after we set up our shared license server.

We’re loading our Ragdoll plugin in the same way and using the same RAGDOLL_FLOATING environment variable value.

When looking at the connection in the License window, we’re both reaching the same machine on the same port, but for the other user, their License is a “Trial (floating)” license while mine is an “Unlimited (floating)” license.

Is there a setting that could be lurking about their Maya prefs that’s somehow marking them as trial users still?

Hi @jstrong, hm, I got a report earlier today about a similar-sounding issue.

Can you confirm whether this works for you:

  1. Launch Maya
  2. Load Ragdoll
  3. Make a cube
  4. Assign to it
  5. Record it, past 100 frames

This should work, without being limited by 100 frames, is that the case?

If so, save that scene. And open it. Are you seeing a popup/balloon appear, mentioning something about downgrading your licence to Personal/Trial?

If so, you might have gotten stung by this bug.

There is a link to a downloadable version with a fix in that link, and every newer version since will have had this patched up as well.

Let me know.

Edit: Does your licence server acknowledge the leasing of licences? Can you tell whether it’s responsive at all? It should say something along the lines of…

PS C:\Users\konst\Downloads\TurboFloat-Server-Windows> .\TurboFloatServer.exe -x
2022-06-15, 18:31:48 <notification>: Auto-detected 8 CPU cores; creating a thread pool that large.
Floating license server for Ragdoll Dynamics (TFS v4.4.4.0)
2022-06-15, 18:31:56 <notification>: New connection from IP: ::1
2022-06-15, 18:31:56 <notification>: New lease assigned (konst, 1, IP=::1, PID=24744). Expires: 2022-06-15 17:32:26 (in UTC). Used / Total leases: 1 / 1

I tried the steps. Things work perfectly well for me, but I never saw the issue. I’ll pass the steps to the user running into the problem.

Ok, great. And in the off chance that it’s a simple configuration issue, make sure the users having the problem can run this - in a Python tab of the Script Editor.

import os

It should not throw an error, and should print out the address to your local licence server.

Thanks, I’ll give that a try!

The user tried removing all ragdoll nodes in their scene and starting over from scratch.

It worked for a while, until their scene crashed. Upon restart, they’re getting trial messages again.

Would it be possible to show me a screenshot of this message?

Another update.

The user is reporting that when they just open the scene and try to hit play, they’ll get warnings about the license being expired. The license window says “Trial has expired Expired: 15 June 2022”.

However, if they run our tool that registers/loads the plugin, then things work.

Ahaa, a very relevant clue.

What needs to happen is for that variable to exist before launching Maya. I suspect this is what your launcher does.

If a user were to, for example, double-click a Maya scene from Windows Explorer, the variable would probably not be present, or is present after having loaded the Ragdoll plug-in.

To work around this, and possibly solve it and call it a day, your users can manually add this variable to their system. Since I think you are on Windows, here are some Windows steps.

  1. Open the System Environment window
  2. Add a new variable, called RAGDOLL_FLOATING
  3. Give the value your launcher does, it will be something like or licence_computer:8002
  4. That’s it.

Here’s where to find the Environment window, from the Start menu.


And here’s what to add.


Thanks! I think we’ve got everything sorted now!

Inserting the envar into our setup process seems to have fixed the problem.

1 Like

Fantastic, happy to help! :partying_face: