Unreference / Replace reference on Ragdoll rig causes Maya Crash

Hey there,

I am noticing that Maya crashes if I try to “unreference” or “replace reference” a rig that has markers applied to it. If there a solution for this?

After noticing the issue with creating constraints over two different solvers after undo, I imported my monster character into my crab rig file, merged solvers, then saved over the original crab rig file that was referenced into my animation scene. When I open my animation scene now, I have two of the monster characters, one from the crab reference, one that was already there.

I was thinking I could just hide the old monster but for some reason the new monster rig, from the crab rile, has only one leg showing up in Ragdoll form and I am getting this error:
// Warning: Ensure both ‘crabRig_v006_publish_0004:rMarker_Titanockarce_Body’ and ‘crabRig_v006_publish_0004:rMarker_Titanockarce_LegLeftMiddle_1’ are part of the same solver.’ //

The referenced monster rig that was in there before is also now missing from ragdoll… It seems because these rigs were named so similar Ragdoll has gotten confused about which marker is assigned to which solver. Linking solvers does not fix this, and this does not happen when importing the new crab + monster merged file into a new scene!

I’m thinking the only way to unconfuse Ragdoll about this is to remove the old reference, but Maya crashes every time I do this. In the meantime I am going to try and rename the imported monster rig and see if that fixes my issue. Any help is greatly appreciated.

I am using Maya 2022.


I have just renamed all nodes on the monster that was imported into the crab scene, and I’ve also overwritten the original monster rig with an empty scene. Now when I open my animation scene I only have the one monster that from my crab reference file, but alas I am still getting this error:
// Warning: Ensure both ‘crabRig_v006_publish_0004:rMarker_Monster_Body’ and ‘crabRig_v006_publish_0004:rMarker_Monster_LegLeftMiddle_1’ are part of the same solver.’ //

…and I still have the same issue in my scene. No ragdoll on any of the monster except for the one leg.

Oddly enough, there is only one solver in scene now. I’m stumped. Is there any way to fix this problem?

I’ll investigate this @Cody, for the time being are you familiar with:

  1. Save as .ma
  2. Open the .ma in a text editor, like Notepad
  3. Replace the reference path

It’ll be one of the first lines in that .ma file, no matter how large it is.

1 Like

Had a go with this, and realised I reference and replace references all day every day and haven’t run into this problem.

Are you able to reproduce this with a series of steps I can follow? Such as…

  1. Reference crabRig_v007.ma
  2. Replace Reference with the same crabRig_v007.ma
  3. CRASH

This particular example works fine here.

Hey Marcus,

I am still using crabRig_v006, might that cause any issues?

I tried importing the crab rig into a new scene and both unloading the reference, and replacing the reference with the same file. Both cause crashes :frowning:

What version of Maya are you using?

Perhaps this has something to do with it? I received this message when trying to delete physics from selection.

Quite likely, yes. Nobody should be using 2022.0, it was a dumpster fire.

OMFG. That was my issue!!! I was losing my mind over here. If I tried to delete constraints, Maya crashed. Unreference, crash. Maya was crashing left and right and I was worried it had something to do with Ragdoll, but I’ve just opened the project in 2023 and deleted a constraint with no issues. Ahhhhh!

1 Like