Snap and record markers question

Hi Marcus!

I have tried to use Ragdoll Dynamics and so far everything has gone really smooth. But now I want to snap the character for doing a little back and forth and looks like that I can only snap if the markers are not animated at all. Am I assuming right? If so, is there a way of snapping other than removing all the animation in the marker?

Related to this: When I want to record the simulation into the markers, the record range options are blocked and grey. Is it normal? I am using Maya 2022.


Hi @Juan!

Hm, snapping should bring your rig to wherever the Markers are at the time of snapping. Is this not what you are seeing? If you could share a screenshot or recording of what you see that would help narrow things down.

At the moment, yes the UI doesn’t let you set the range. It’ll use the range of your timeline in Maya, or the range you have selected in your timeline.

See here for details.

Hi Marcus,

Thanks for your answer.

I have prepared and example video of the issue, but looks like I am not able to upload it in here. I could describe the issue saying that as long as the markers have any keyframe in them, snap to simulation is not working anymore.

Understood for the range options and how to solve the problem.

Thanks again!

Thanks, I got the video via email. Although I should really make it possible to upload video here, will investigate this too.

As for the issue, one of the things I spotted was that Cached Playback was enabled. Did you get any notification about this when starting to use Ragdoll? It doesn’t cope too well with Cached Playback, and it should have given you an option to disable it.

I suspect this is the cause, but will investigate this more closely. Thanks for reporting this!

Ps. the way I upload video is by uploading it on GitHub - into any issue, without actually posting it on GitHub, such as this one - and then pasting the link to the video here. That way it saves on storage and backup costs on this forum too. :angel:

The message I get when trying to upload the video is new users are not allowed for attachments. So it is most likely a permits issue. However, GitHub hosting seems like a much more efficient way.

I can’t remember any warning about Cached Playback when first starting Ragdoll. I tried disabling it, but with no result. I thought maybe it had something to do with keyframing conflicting constraints in Maya, but I could not find a constraint blend attribute.

Thanks for looking into the issue!

Hi @Juan, I’ve replicated your example here and can reproduce the issue. Will fix this for the next release, thanks for reporting this!