Scene Scale

If you’re getting Jittery simulation - check your actual scene scale,
in this video I have debris falling and got some fast calculation times BUT if these chunks are too small I get slower simulation times.
One suggestion is to simulate your scene at a larger scale and scaled your scene back down.

This is because of a different variable, also called “Scene Scale”.

The problem

When things move too fast and are too small, things will have trouble coming to rest. It’s because of assumptions Ragdoll makes about the overall size of most objects, and per default it assumes that no object is smaller than about one Maya grid cell (1 cm).

The solution

This generally only needs to happen once per studio or per project or per user, as most things are safe to assume to have a relatively similar size to each other.

  • Go to Ragdoll → System → Preferences
  • Set Scene Scale from 10 to 1

This however will not have an effect until after you reload the plug-in.

Elephant in the room

What is the difference between Scene Scale in Preferences and Scene Scale on the rSolver node?

Yes, these are poorly named…

  • Preferences Scene Scale refers to internal thicknesses, specifically related to motion coming to rest
  • Solver Scene Scale refers mainly to gravity and how quickly things fall

You probably didn’t know about Scene Scale in Preferences, nor have you ever had issues with things coming to rest without jittering. Because naturally, you tend to size things relative the Maya grid. And that’s good! That’s the assumption the default values were based on.

But sometimes, like in Jason’s scenario above, you encounter a scenario where it would be useful.

Why not keep a low Preferences Scene Scale all the time?

I invite you to try! There is instability at the other end of the spectrum as well. Where things that are too large start having trouble coming to rest. It’s a hard problem, as is scene scale in general. Hence this is a user-tweakable variable, such that you can find what works best for you.