Rotate Limits

Hello Markus
Looks like im not understanding how the limits for the rotations work. They seem to be just ignored by the solver. Also tried to change settings, but without any difference.
What am i missing?

Scale is important here. In the upcoming release, this will be less of an issue, but at the moment if your character is any taller than 20 cm then you need to tune the global limit stiffness and damping values you found there.

Try these steps to build some intuition about this.

  1. Load the default Manikin character
  2. Play the simulation

You’ll find limits will act as you’d expect.

  1. Scale that Manikin (the skeleton_grp) by 10x
  2. Change the Scene Scale attribute on the solver from 0.1 to 1.0.

Gravity will behave as you’d expect, but now limits are weak to non-existent.

  1. Increase the Rotate Stiffness in the Limits tab of the solver by 1000x
  2. Increase the Rotate Damping by 1000x as well

It’s 1000x, because with a character that is 10x as tall, he is also 10x as wide and 10x as deep, and 10x10x10 = 1000x more mass.

At these values, you’ll find your the Manikin being mostly the same, but at these magnitudes, even Maya’s number boxes struggle to show you the final value. And it would be unable to increase that value by another 10x (even though Ragdoll is fine with it). So a character 200 cm (i.e. 200 default Maya units) is currently a kind of max for the current version of Ragdoll.

The next version addresses this, so by the time future readers see this thread it will have become a thing of the past. :partying_face:

Let us know how you get along, it’s possible scale is not your issue in which case we can explore some more options!

1 Like

Cranked it up to max and it works as expected now :rofl:
Thanks for the detailed example, gives me a better understanding!

1 Like