River Crossing Crab

Hello everyone :slight_smile:

I am going to try and make a short animation, a crab jumping rocks to cross a river, with Loco Motion.

https://user-images.githubusercontent.com/3357009/177192374-e456f3cc-70f0-4d57-ab95-aeaeeca5cd04.png

Disclaimers:

I have almost no ideas about the workflow and only seen a livestream that hosted a few days ago with documentation on the release page. :blush:

So the first thing to do is testing how loco motion works, and how to walk and jump.

Some notes:

  • When planning with a ground plan that has not marker assigned but an environment, seems not working.

  • Can have only one terrain. But you can combine all meshes and leave the history as is.

  • Cannot change plan preset once created. (e.g. Jump/Walk)

  • Cannot freeze transform on body and foots.

  • Terrain seems cannot have gap? Or its res not high enough? Wondering if there is a way to visualize what exact mesh/volume that loco engine sees.

    Untitled

    I made a gap in between because I thought Loco motion will automatically change to jump from walk :laughing:. But, still a bit strange that it landing foot on a point that is not on the ground.

    https://user-images.githubusercontent.com/3357009/177196597-4fc40801-59dd-41cf-81c1-7f03f53abff9.png

  • Limit mode flickering bbox (nvm, its because CachePlayback was enabled)

  • Need to turn off CachePlayback.

  • Limit mode doesn’t have mirror edit if not in center, e.g. foot.

  • Stuck in “Thinking…” when the plan actually updated (message showed in ScriptEditor) and the status changed after I click/move the mouse again. (I cranked up the iteration count so I waited for like 20 secs and found this issue)

  • Maybe we should have plan blending? At the moment I can blend plans with keying the attribute “blend” on each body parts.


Ok, that’s it for today. Will try to update at least once a week! :wink:

Heya, thanks for posting this. :blush:

Correct, there is only 1 attribute for the geometry, but that geometry can have any complexity and any number of combined meshes.

There will be a button to “reset” a step sequence to some pre-defined preset like those in the Assign Plan option UI. But yes, at the moment you would need to (1) delete the plan and (2) assign it again to reset the step sequence.

Indeed, something to look out for! It may still compute a plan successfully, but it will look at the body and feet as though they were all at the origin… If you do have complex controls, your safest bet is to assign a plan to a fresh set of locators, and either use Maya’s Parent Constraint to transfer the result to your rig, or to parent your controls under these locators.

They can, but it would need to actually physically be part of the geometry.

When there is missing geometry, Ragdoll will fill in the missing bits with the closest geometry around that hole.

Yes hah, best to physically make the missing ground as well. Even if that means putting another box below, representing the ground underneath these platforms.

Coming soon!

Are you able to reproduce this? The only time this should be the case is when it is actually thinking… And it should eventually finish.

Do you mean you can already blend plans (which you should!) or that it would be nice to have?

Upon assigning the first plan, that Blend attribute is between the original animation on the controls you assign and the new plan. Upon assigning the second plan, the original animation is the first plan. So the attribute should let you blend between the two plans.

1 Like

Will have that locator setup a try!
Yeah, plan can be computed successfully but all the path endpoint controllers in Target Mode collapsed together, so better to watch out!

Somehow I cannot reproduce this anymore :flushed:
:confused: Maybe a false alarm :sweat_smile:

Oh yes, we can blend plans already for sure :slight_smile:
But have to do it manually and could be a bit confused for the first time. Following video is how I blending plans.

  1. I started with a simple walking plan (duration 50), and I’d like to make that three legs monster to jump at frame 51.
  2. So I add a Jump plan, and change the start frame to custom 51, duration 50 so that makes a 100 frame animation.
  3. However, the monster didn’t move during 0-50 after I made that change. Until I set key to the attribute blend.

I am thinking maybe we could make those plans blending together automatically once assigned? And add options to set start frame and duration in plan assigning options dialog, so we could see the full picture right away. :slight_smile:

Oh and, to be super convenient, maybe we can snap the start point of the current plan path to other plan’s path endpoint? :nerd_face:

Good idea. :slight_smile: Seems doable.

  1. Set start time of Plan 2 to when Plan 1 ends
  2. Set start target of Plan 2 to where end end target of Plan 1 is
  3. Set a key on the Blend attribute automatically, to transition between the two