Replace Mesh Selection Problem

Hi there, I’m getting this popup when using the ‘Replace Mesh’ function (I’m setting up my character to use custom geometry instead of spheres/cubes/capsules):

‘UserWarning: 2 or more geometries were selected, but not all of them were polygonal meshes.’

I’m able to use it successfully for awhile, but all of a sudden won’t let me complete or redo with new geometry.

I even tried creating a default cube, selecting my controller, shift select the cube, and hit ‘Replace Mesh’, and it still gives me this error.

Is there a setting on the controller that I need to adjust to get it working again?

Hey Ben,

I think what you are seeing is because your control may have multiple shapes, and Ragdoll can’t figure out whether you mean the second selection you made, or one of the other shapes on the controller. Because the selection is independent of the order in which you select.

Here I’ve tried to reproduce what I think you are seeing, first the case that does work followed by what doesn’t. Notice how that last control has 2 shapes.

What you can do instead is be more specific in your selection.

  1. Select exactly 1 Marker
  2. Select exactly 1 mesh

You can select a Marker either via the Outliner (it’s a DG node) or the Channel Box, so long as you then deselect the control you originally select to make it appear in the Channel Box.

Let me know if this works for you!

I see. I didn’t realize that my controls had multiple (sort of hidden) shapes. Thanks for your solution! It works perfectly now.