Recorded Simulation Not in sync with markers?

Hi Im sure im doing something incorrectly but
i test simmed the shark, looked fine, looked fine when recorded but upon playback isnt correct.
maya 2020 windows 10. the latest RD version 10.10 heres a short vid clip of it occurring/ ty

Oh dear, great work finding this. However, I’m unable to reproduce it. :sob:

Is this what you did?

Would it be possible to record the steps you took to get to here? Alternatively, just a list of steps, such as:

  1. Start a new scene
  2. Load shark
  3. Delete default pin constraint
  4. Make new pin constraint on fin
  5. Record
  6. Profit

Hi marcus in
The vid clip i sent i opened the default rd shark
Added a pin to one of the tail markers
Deleted the default pin
Adjusted couple parameters and added a few quick keys on shark body and tail
Thats it. But ill reproduce/record it for you later today. Thank you for always answering so quickly

Thanks, that is indeed strange. The video I made, if you follow it, do you not get the same result as I? Can you also confirm whether the root joint of that shark has animation once you record?

I will check that too although wouldnt that show in the recording process while baking keys?
Pretty sure the root joint is set to simulation but ill def check. Thanks Marcus

In your video, the shark does appear to follow the simulation during the record process, but only joints other than the root seems to be getting any keyframes from it. So I’m curious whether your root is without keyframes, if it only has 1 keyframes, or 0.

I opened a new scene. opened RD shark, deleted the pin constraint, created a new pin cnstrnt on the tail, keyed a few frames on neck, simmed, recorded and worked fine, so heres the maya 2020 file where it occurred… there was no keyframe on the shark root nor was the shark root marker set to ‘animate’ (133.9 KB)

found it
the limits on the root marker were all set to ‘locked’
unlocked them all and works fine

Thanks @hockeypuck, I can reproduce the issue here now as well. Investigating!

Ok, I’ve got it. This one was subtle, we will need to think of a better way to visualise this in the UI or viewport somehow to avoid more confusion. Even I wasn’t able to spot it easily.

On each Marker, there is an option to enable/disable recording of translation and rotation.

In this case, the Record Rotation has been untoggled, meaning Ragdoll would not set any keyframes on it. In the default asset, this is enabled. So this must have someone become untoggled after you imported it. It can be done either via the Attribute Editor here, or the Manipulator.

As I said, subtle, but hopefully this should get you going.

1 Like

Thanks Marcus!:slightly_smiling_face: