Record Simulation Problems

Hello! I am using v2022.03.15 and for the past couple days I am unable to finish recording the simulation, it stops at the “finishing” step, with 95% done and from there on it just hangs locking the Maya session. It’s set to record to layer, ignoring bones, nothing different from usual. The one element that might be important is that the baking is done with imported physics setup.

it is a very similar situation as here: Recording Simulation in Unlimited progress stuck at 0% - #20 by Geordie_Martinez

in my case the process stops at 95%

Thank you very much

Hi @frasu, welcome to the forums and sorry to hear Ragdoll is giving you issues.

Can you confirm whether…

  1. Did recording work previously, and this only recently started freezing?
  2. Are you on Windows, Linux or Mac?

Here’s a few things to try.

  • Try recording in a new scene, with just a box.
  • Try recording with Maya set to Serial or DG evaluation mode, rather than Parallel.
  • Try the latest version, 2022.06.09
  • Try Ragdoll → System → Reset Preferences

95% is interesting, that’s where the Rotation Filter is applied. So also try…

  • Set Rotation Filter to Off in the Record Simulation options dialog

Other than that:

As a workaround, can you try this.

  1. Ragdoll → Utilities → Extract Simulation

Does that work? If it does, then go into the options and enable Attach Controls


If this works, you are half-way there. Your controls are now constrained to the simulation, the remaining step is to bake it out. So run Maya’s Edit -> Keys -> Bake Results command.

And let me know how it goes, and we’ll continue from here.

1 Like

One other thing came to mind (thanks @Jason), especially with regards to the old version you’ve got which had a problem with converting any commercial licence back into a Personal licence.

At 95%, a popup could appear telling you about the 100 frame limitation of a Personal licence. And it’s possible this dialog either appears off-screen or is simply the cause of locking up Maya.

You can disable that popup here.


It’s a bit of a long-shot, but let me know how it goes.

Thank you for the speedy response!

The record option worked fine in the file I setup the ragdoll rig. It happened only in the files I imported the physics to. I am on Linux. I did try the DG and parallel settings and flipping the rotation filter.

I tried the extract simulation option! It’s great, didn’t know that will actually parent the ctrls. It works great, I am using this solution for now and revisit the other suggestions another time. But I am happy that the RG utility works as a solid backup.

Thank you Marcus, thank you Jason