Record Simulation on single object not working


I am trying to do a very basic cube dropping on ground, but when I record simulation it’s not copying the sim animation, any idea why or what I did wrong?

Here are the steps I did:

  1. Create a cube, moved it higher and angled it a touch
  2. Select cube, ragdoll → assign
  3. Press play and the rSolver ball is dropping nicely
  4. Select cube, ragdoll → record simulation
  5. It bakes all the frames on a layer but they are all a straight line

Thank you.

Hey @feiyuen welcome to the forums could I have a look at a screen shot for your record settings ? Something might be unchecked .


Hi Jason, thank you for your reply, here’s a picture of the record setting.

Actually, I switch to “Fast and Loose” and it works.

What’s the different between “Fast and Loose” vs “Nice and Steady”?

1 Like

Hey @feiyuen, welcome to the forums! :partying_face:

I’ve tried replicating your steps here, are you seeing something different to this?

Nice and Steady will update the viewport whilst recording, whereas Fast and Loose will not. Some character rigs depend on viewport updates and can’t be updated without it. In the case of a box, it’d be safe to use Fast and Loose and reap the performance benefits.

Hi Marcus, thank you for your reply. Yes, that’s exactly what I am seeing in Maya before record simulation, except “Nice and steady” doesn’t bake the anim onto the box, only “Fast and Loose” will bake it correctly.

But this is fine, as long as I am able to bake the anim in one of the option.

I’ve been learning this program for the past couple days, I absolutely loved it and hoping to utilize this in our production.

That’s very strange. Can you tell me which version of Maya are you using, and what platform? Do you have anything special you can think of, such as DG evaluation as opposed to Parallel evaluation? Any special renderer, other than OpenGL or DirectX? And what about Cached Playback, this button here?


Maya version is 2020.4.0 on Linux, there’s probably a bunch of other stuff our company written into it while launching.

Interesting though, I tried “Nice and Steady” on DG and it works, I hit “Ignore” when there’s a pop up saying Ragdoll is most optimal with Parallel (when i select the cube and hit Ragdoll → Assign)

Nothing i can think of about OpenGL or DirectX. The cache button is there, but it’s not enabled (it’s grey out).

Interesting indeed. I haven’t come across this before, please keep us updating with any other oddities you discover and potential signs of your environment being in any way different from a typical setup. If you try this on another machine for example, like your own home laptop or the like, I’d be interested to see if anything differs.

Also try Ragdoll → Utilities → Extract Simulation.

That’ll generate a standalone hierarchy with your physics as keyframes. This is what the Record mechanic uses under the hood, alongside parent and orient constraints to drive your rig, and the Bake Results command in Maya.