Kinematic delay 1 frame


I am doing some test with ragdoll. Ran into an issue, that I am not too sure how to fix.

using version 2022.12.22

I had ragdoll set up and switch to kinematic. But when the animation start, theres a 1 frame delay from the ragdoll.

I wonder what could cause that!

Hey @kaehwai, good to have you back :partying_face:

Looks like you got hit with this bug, fixed in 2023.04.01

Hey Marcus,

Yeah, Happy to be back!
I guess since I am using older version, this meant that. Have to restart the scene set up?

Every release of Ragdoll is 100% backwards compatible for well over 2 years, so if it isn’t working once you update then that’s unexpected and a bug, please let us know!

Thanks Marcus!

Actually, I am trying to test the software on a company network.
hehe, I am trying to get more users onboard with Ragdoll workflow!
Might take a long time to get the update version! < I will request for the update from pipeline.

But probably easier if I restart it for now.

Thanks again!

Hey Marcus,

I realise regardless of how I restart it. The frame delay is recurring.
I am using maya 2019. I wonder if theres a preference setting that could break that.

I give the ragdoll version a try with maya 2023. And we do not see the delay.

swapping between dg and parallel seems to fix the issue!

Hm, one solution is to simply set your kinematic keyframes 1 frame earlier. It’s literally being read from Maya with 1 frame offset, so that should handle it completely.

If it doesn’t, and if it’s fixed with DG, that sounds different. Are you able to reproduce in a scene you can share or post a video of? E.g. with a single joint chain or just a cube?

Hey Marcus,

I see, I think this is fixed with changing from DG to Parallel evaluation. I cant share screenshot as I am on a close network.

I am using maya 2019.3.1

with an empty scene, I created a sphere with ragdoll assigned.
If I am using DG evaluation I can see the delay.
If I change to Parallel, the issue is gone!

Can confirm switching from DG to Parallel fixed this for me as well. Thanks Kaehwai.