Invisible marker / ground geo

I have some markers which when I simulate them they will not drop below origin (0) They simulate and interact as if I have a ground plane in the scene, which I do not (at least not one I can find).

I do actually have some other markers which seem to simulate as I expect (dropping below zero ) , but I am happy with their movments so I have set that group to kinematic whilst I work on the other markers.

Any ideas of where I should look?

some additonal context… my scene is very large (in scale) with both big and smaller markers. Any new markers or groups I create seem to act the same way.

I have searched the scene for rground etc… nothing obvious there.

Hi @Bernie, Ragdoll has no sense of a ground plane other than the default flat box it creates when assigning to your first Marker, which is itself another Marker.

To test, you can try this.

  1. Ragdoll → Select → Markers
  2. Set Collide = false

This will keep anything from colliding, and I expect your Markers should at this point fall through the floor.

If you are able to show a video, or reproduce the issue in a new scene that you can send, or export a .rag file from, that would help narrow down the issue.

Thanks Marcus!

Super interesting. I did that… everything falls tthrough the floor as you would expect. But then I enable collide on just 1 marker - and it hits an imaginary ground plane…

Im not sure what I can send you atm… I need to be careful as I am in production. Will look into it and get back to you. Any other ideas to try?

Very odd.

Are you able to open a new Maya scene, make a cube of similar size to your production scene, and reproduce the problem?

No. Infact, I used the delete all physics, and created fresh markers/ solvers and it all works as expected! So crisis averted from my end.

Appreciate you probably need a file to diagnose this one. I will try and see if I can send you something.

1 Like