Collission shape issue with custom rig

Having this problem with collisions regarding previously build leg rig.
So i have replaced the collission shape for the selected control that is part of the simulation with the bone mesh:

But its, of course, not matching the bone mesh since it is skinned to the other joint that is constraint to the control

How to solve this matter, if its possible?

I’m not 100% sure I understand, but it sounds like the mesh you’ve used with Replace Mesh is deforming.

Ragdoll will use whatever the mesh looks like at the start frame, and keep it that way during the simulation. Normally, that’s helpful in case you want to add/remove points from it after you’ve assigned. But in this case, it sounds like you’re better of not ticking the “Maintain History” option in the options for Replace Mesh.

That will store a version of the mesh as it looks at the time of assigning, which sounds like what you expect.

No its not the mesh for the collission itself that is the problem, but which joint it is “parented” to.
Let me put it this way. This is the rig for the knee from the previous topic

There was the knee joint controling the marker and therefore the collission shape like in this pic

And the IK joints rotating the knee/fibula mesh in the correct way like here, which are not part of the sim and therefore have no collission shape.

So the problem is, if that part is colliding with something, it will go through the knee/fibula mesh.
Hope i could make the issue clearer. English isnt my native language

Hm, would it help if you could use both meshes? You can combine one or more Maya meshes into a single shape, and use that with Replace Mesh. That would cover contacts with both the mesh you have already assigned, along with the mesh for the fibula.

Its not the meshes, i could use the capsule shape. Issue is that the colliossion mesh is not matching the fibula mesh due to the collission mesh/marker is being driven by the other joint.
Is there a way to make that marker follow the fibula instead?

Aha, it looks like you need the Markers to not only rotate, but to translate too. On the Marker, there is an attribute called Translate Motion, try setting this to Soft.

Ideally though, if you want anatomical correctness, I would model the markers anatomically as well and aim for rotate-only behaviour. Our human bones do not translate, so there must be a way to model it without translation.

Couldnt understand why to use soft joints in this matter, sorry.
Yes, the whole point is to have anatomical correctness, so of course soft joints are out of the question. And again the problem is not the shape of the marker, at least not now, but because the marker isnt effecting the right joint

Hm, I must admit I’m struggling a little to understand. So I took a stab at this myself, would something like this work for you?

skeleton_test.rag (63.1 KB)

You can use Load Physics from the Ragdoll menu with that .rag file to generate this scene on your machine.

Yes that goes into the right direction, it is basically the same rig i have but without the control joint that is constraining both knee joints (joint 3 and 5 in your example).
How do you rotate those in your example vid?

I’ve included my scene for you to experiment with, it’s really just 3 bones that I rotate manually.

It’s not clear what the “control joint” is doing or what purpose it serves? It is not possible to rotate the knee and lower leg joints with that control joint without the knee and/or lower leg changing in length. If you want to include changes to length and position, that’s where you’ll need the Translate Motion attribute.

If you really need to keep the control joint, I would suggest:

  1. Assigning an IK handle to the knee and lower leg joints
  2. Point Constraining the IK handle to the tip of your control joint
  3. Assigning Markers to the knee and lower leg joints
  4. Retarget the lower leg to your control joint

That way, you can ensure that no translation takes place, and that the animation still ends up on your control joint.