Can't work with manipulator windows

Hello Everyone,

I’m trying to manipulate solver shapes but when I click on something within grey manipulator window then the shape becomes deselected. It seems that Manipulator menu in viewport is unclickable. There is also an issue when I try to change shape parameters from normal channel box menu.
Did someone encounter such problem and know how to deal with it?

From what I see Manipulator recognizes mouse actions and I can select solver shapes, but nothing more. Also, the same problem occurs in Maya 2020, and resetting preferences didn’t help.

Problem disappeared suddenly. I didn’t change anything in preferences since my latest post, just worked with keys.

Welcome aboard @FilRagdoll, sorry for the late reply but good to hear you managed to find a way around it.

I was going to ask which version of Ragdoll you are on, along with which platform - e.g. Windows? - and finally whether your Maya is set to OpenGL or DirectX mode. Also, the manipulator is only visible on the start frame, could that be relevant?

Even if it works at the moment, would still be helpful to know the answers to these questions.

Hello Marcus,

I am using latest release and Windows 10 Pro. I tested both OpenGL and Directx modes, and I am aware of the first frame rule.
The problem appeared again today. When I launched Maya everything worked properly. Then, after playing with limits, solver stiffness and damping for 30 minutes, the problem reappeared. I can’t do anything within Manipulator grey windows.

That is odd, haven’t heard of this before. Can you think of any way of reproducing it, other than using it for 30 mins?

Also would you be able to record or even screenshot a situation where this happens?

I have a record, but I can’t upload attachments as a new user.

Sorry about that, please try again. It’ll need to be a smaller attachment, less than 10 mb or so. The shorter and smaller the better.

I sent it also via email - assuming You are the same Marcus who contacted me regarding the license.

Got it, thanks. I see what you mean. This used to happen in an older version, can you confirm that you are on 2022.01.17 or newer?

It was fixed here:

I am on 2022.01.21.

I’m unsure why this happens. Is there anything special about your setup worth mentioning? E.g. 4 graphics cards, 6 monitors? :smile:

A few things to try:

  1. Reloading the plug-in. I assume this fixes it, although it’s not very pleasant.
  2. Exiting and re-entering the manipulator, e.g. hitting Q followed by T
  3. Entering the manipulator by (1) selecting a marker in the Channel Box and (2) hitting T
  4. Entering the manipulator using the Ragdoll menu

If you find some reproducible way I could use to make it happen here, that would be fantastic. If nothing else works, maybe we can jump on a screenshare session for a closer look. Later today, in about 3h onwards, works for me.

Unfortunately none of those things helped. I use 2 monitors, only one graphic card and I think there is nothing unusual about my setup…

…what helped, exactly now, was closing teared off panel in Maya. I thought it was second monitor, but using ragdoll on duplicated view was the problem.

Ah! I can confirm this here, thanks for this. Clearly a bug, will fix this up for the next release. :smiling_face_with_three_hearts:

1 Like