Manipulator Disappearing?

Seems like I can’t get a smooth ride today lol this all of a sudden started happening, I need to set up some rotation limits on some of these markers but soon as I click on anything the interface disappears. I know someone else had this issue back in January, and it was on Ragdoll 2022.01.17, but he was using 2 monitors and that seemed to have been the issue, and somehow the problem sorted itself out.

In my case I’m running Ragdoll 2022.02.17 on Maya 2022 (Using Python V2) on a Windows 10 machine, Maya is set to DirectX, and I’m only using 1 monitor, and 1 GPU. My monitor’s native Resolution is 1080p but I run it at 1440p (it’s a 27inch monitor) so that I have the 1440p scaling which gives me more room within Maya for all my windows etc.

Don’t know what else to write tbh

Try ticking this checkbox here.

It shouldn’t be necessary, but it looks like something it not right. This checkbox will select the corresponding Maya node whenever a Marker is selected in the Manipulator.

Try to update your Ragdoll too, February is old and I can’t remember what worked and didn’t work so it’ll be more tricky to understand any issue that pops up.

I’m using the CG Spectrum floating license, is there a different way for me to update to the latest version of Ragdoll or do I just download it from the website and install it as usual?

Download and install as usual. :+1:

okay so I’ve updated to the latest version of Ragdoll however the issue still persists. Even if I restart Maya I keep getting the same issue

Odd, you can setup rotate limits via the Channel Box also, they are also available in the Attribute Editor.

For the bug, does it happen in a new scene? Or only in this particular scene?

It’s really only happening in this particular scene, on a new scene it’s working as intended

In that case, I’m very interested in that scene. :slight_smile: Could you try this?

Import any reference currently in use and:

  1. Delete half the scene
  2. See if the problem persists
  3. If no, return to 1, if yes return to 1 but delete the other half

At some point, it will start working again. Even if it takes deleting almost everything. If you can upload this scene, with as much deleted as humanly possible or better yet reproduced in a new scene, that would help a lot.

I can probably upload the scene however the rigs I’ve used are all referenced in so you’d need those as well. As far as I know they’re all free rigs made by Truong CG Artist so I think I should be able to upload it. But I’m not 100% sure

I suspect very few things in the scene are necessary for the problem to persist; try deleting as much as humanly possible. Importing any references.

Okay so I’m still getting this bug and I just did the following:

Selected all controllers with keyframes on my rigs and used ATOM to export the animation.
Create a brand new scene, reference the rigs, used ATOM to bring in those keyframes.
Went back on my old scene file, selected the background geometry, exported as FBX, then go to the new scene, import said geometry.
Rebuilt lighting from scratch, rebuilt display layers from scratch, rebuilt cameras from scratch.
Then I imported the Proxy meshes for the markers.

After trying the manipulator still has this same issue. I really don’t know what to do next.

Ok I tried turning on/off the referenced rigs, so I think that’s the issue, as soon as I reference the rig the manipulator stops working.

Okay so it’s 100% referencing rigs that causes it. I just regularly imported the rigs into a new scene, and now it’s working as intended.