Imported physics loosing edit mode

Hello! I am sure I am missing some basic option at the time of exporting or when I import, but I am not able to figure out why I am loosing all edit attributes on the markers. I have the physics attributes (dampening, density etc.) but the scale or translation offset are missing even when going in the “Manipulator” mode. I am not able to reposition markers that are off from the initial setup or rescale them. I hope it makes sense.

Thank you

Hey @frasu, I’m not entirely sure I understand what you mean. Do you mean that if you…

  1. Make a box
  2. Assign a marker to it
  3. Change the Damping and Density attributes
  4. Export Physics
  5. Then Import Physics onto another box

At this point, Damping and Density attributes didn’t come with?

If so, closest thing I can think of is this option here.

the damping and density attributes are there but I don’t get the shape attributes that I wanted to change… offsetting, rescaling or rotating the marker. I am trying the fix one of the markers that comes in off from what I built and exported and I am not able to move it around in the imported file.

Hm, would it be possible to record the process? From e.g. just exporting a box and taking that through to where you are having the issue. It would enable me to reproduce it here, and see more clearly what the problem might be. As a video I mean, and upload it here?

the attributed on the imported marker
attributes available at export

So I am missing the shape attributes that will allow me to further change the marker in the imported file.

But I also figured out why I am getting an offset when importing the markers. When I created them initially, I did a replace geo for the marker with the option "keep offset " on and that is getting me to have certain markers in the wrong position when imported to another character

Aha, ok yes I see what you mean. They are no longer visible in the Channel Box.

The default behaviour for Markers is to not show some attributes, to let those be edited via the Manipulator instead. You can toggle the visibility of these after import, via the Utilities menu.


To your other problem, of shapes having the wrong offset. The offset should definitely be kept on import, but is it possible the meshes do not get imported properly? The importer is very sensitive to the names of your meshes, they need to have exactly the same name, ideally the same namespace too. If the meshes cannot be found, it would ignore the mesh and the offset for that mesh.

oh snap! amazing hahaha… That did it… thank you so much @marcus

1 Like