AssertionError: Must call `_sim_to_cache()` first

Hi there,

I am trying to record simulation but upon hitting the magic button I am getting this error:

AssertionError: Must call _sim_to_cache() first

How does one sim to cache? I have tried caching, uncacheing, etc, and still no luck.

Any help is much appreciated! Cheers

Hey Cody, can you let me know what steps you took to get that error? How can I make it happen here?

It isn’t something you are supposed to do, this would be a bug. An “assertion” is something the code is assuming should happen, so when it doesn’t then something else is wrong.

Sorry, this occurred on my Spidey August challenge shot, I would have been more descriptive if it weren’t for the looming deadline last night.

I recorded the first section of my shot, then slid the frame range to the next section, tweaked until I was happy, recorded that, and then upon trying to record the last section (after I have already recorded twice in the scene) I got this error. After recording for the second time but before trying to record for the third time I referenced in another Spidey rig, but for some reason it did not come in okay (None of the controls were visible. I was using namespaces, still don’t understand what the problem was here). I then tried to reference in the Woody rig, but was also running into issues and realized I didn’t have time to troubleshoot, so I removed both the extra Spidey and Woody rig from my scene and instead pivoted to having my main Spidey shoot a web to catch a cube that was falling. Everything seemed to work as expected, but then I got this error when trying to record.

Before recording for this third time I also referenced in another “rope” rig. One strange thing that happen is when first merging solvers I actually had more than two solvers in the scene (the main solver, the Woody solver, and now the rope solver) and it errored out telling me I need to only select two solvers.

I keyed the weights of the BakeResults layers created from the previous records and then merged them to the base hoping for a miracle - but it did not resolve my issue.

Perhaps something got messed up when I tried to bring in multiple Spidey characters? Or when I tried to merge more than two solvers? Here are the project files - Spidey rig, rope rig, and animation file, in case it helps.